<table>
<thead>
<tr>
<th>VERSION ID.</th>
<th>RELEASE DATE</th>
<th>DESCRIPTION OF CHANGES</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.1</td>
<td>April 1, 2004</td>
<td>Draft version</td>
</tr>
<tr>
<td>0.2</td>
<td>April 20, 2004</td>
<td>Inspection-ready version</td>
</tr>
<tr>
<td>1.0</td>
<td>May 26, 2004</td>
<td>Post-inspection version</td>
</tr>
<tr>
<td>1.1</td>
<td>May 27, 2004</td>
<td>Under Enter Comments to Reviewers or Content-Contributors, changed “The text is displayed as ?????” to “The text is displayed as configured in the CSS.”</td>
</tr>
<tr>
<td>1.2</td>
<td>June 2, 2004</td>
<td>Enter changes prompted by beta AP.</td>
</tr>
<tr>
<td>1.3</td>
<td>June 7, 2004</td>
<td>Additional changes prompted by beta AP.</td>
</tr>
<tr>
<td>1.4</td>
<td>June 8, 2004</td>
<td>Added use case for opening an Epic Editor file; deleted use case for finding and replacing an attribute</td>
</tr>
<tr>
<td>1.5</td>
<td>June 10, 2004</td>
<td>Replaced Page Preview with Browser Preview</td>
</tr>
</tbody>
</table>

Location of current version:

http://dmfpro01.cac.cpqcorp.net/Development/getfile.htm?DMFCID=09000fa08036b0b4
## Contents

1. Introduction .......................................................................................................................... 5  
   1.1. Purpose of This Document ............................................................................................. 5  
   1.2. Project Overview ........................................................................................................... 5  
   1.3. Authoring Platform Overview ....................................................................................... 5  
   1.4. Assumptions and Dependencies .................................................................................... 5  
   1.5. Limitations and Design Constraints .............................................................................. 5  
   1.6. Requirements Not Addressed ......................................................................................... 6  
   1.7. Reference Documents .................................................................................................. 6  
   1.8. User Description ........................................................................................................... 6  

2. XML Authoring Application .................................................................................................. 7  
   2.1. Description ..................................................................................................................... 7  
   2.2. Menus ............................................................................................................................ 7  
   2.3. Toolbars ......................................................................................................................... 11  
   2.4. Main Document Pane .................................................................................................... 14  
   2.5. Structure View Pane ..................................................................................................... 14  
   2.6. Context Bar ................................................................................................................... 14  
   2.7. Attribute Inspector Pane ............................................................................................... 15  
   2.8. Element List Pane ......................................................................................................... 15  
   2.9. Options Dialog Box ....................................................................................................... 15  
   2.10. Resource Manager Pane ............................................................................................. 16  
   2.11. Revision Mark Options dialog box .............................................................................. 16  

3. DocBook XML DTD ............................................................................................................. 18  
   3.1. Description .................................................................................................................... 18  
   3.2. Supported Elements ..................................................................................................... 18  
   3.3. Required and Optional Attributes ................................................................................ 18  
   3.4. Required Child Elements ............................................................................................. 18  
   3.5. Doctype Declaration ..................................................................................................... 18  

4. IPDS Cascading Style Sheet for DocBook XML DTD ..................................................... 19  
   4.1. Description .................................................................................................................... 19  
   4.2. Configuration ................................................................................................................ 19  

5. IPDS XML Authoring Template ......................................................................................... 22  
   5.1. Description .................................................................................................................... 22  
   5.2. Content and Structured Markup ................................................................................... 22  

6. IPDS XML Boilerplates ...................................................................................................... 24  
   6.1. Description .................................................................................................................... 24  
   6.2. Glossary Entry Boilerplate ............................................................................................. 24  
   6.3. Image (Block) Boilerplate ............................................................................................. 24  
   6.4. Image (Inline) Boilerplate ............................................................................................. 25  
   6.5. Legal Notices Boilerplate .............................................................................................. 25  
   6.6. Numbered Message Boilerplate .................................................................................... 26  
   6.7. Unnumbered Message Boilerplate ............................................................................... 27  

Hewlett Packard
6.8. Event Message Boilerplate .......................................................................................28
6.9. Partition Boilerplate ............................................................................................31
6.10. Question and Answer Pair Boilerplate .................................................................31
6.11. Term and Definition Boilerplate .............................................................................31

7. Use Cases .......................................................................................................... 33
7.1. Install the Authoring Platform ................................................................................33
7.2. Open an Existing DocBook or Other XML Document ...........................................35
7.3. Create a New DocBook Document ...........................................................................37
7.4. Save a DocBook Document ....................................................................................38
7.5. Edit a DocBook Document .....................................................................................39
7.6. Mark Content in a DocBook Document as Changed ............................................41
7.7. Insert XML Boilerplate Into a DocBook Document .................................................43
7.8. Insert an Image Into a DocBook Document ............................................................46
7.9. Find or Replace Content in a DocBook Document ..................................................47
7.10. Insert or Change a DocBook Element .....................................................................49
7.11. Mark Content for Profiling ..................................................................................50
7.12. Enter Comments to Reviewers or Content-Contributors .......................................52
7.15. Auto-Save Work In Progress ..............................................................................55
7.16. Print a DocBook Document ..................................................................................56
7.17. Perform a Spell-Check on a DocBook Document ................................................57
7.18. Copy FrameMaker Text Into a DocBook Document ..............................................58
7.19. Change the Font Size in Editing Mode ..................................................................59
1. Introduction

1.1. Purpose of This Document

This document describes and defines the authoring platform that will be used by Information Product Development and Services (IPDS) content-contributors to create structured and valid XML content for all DocBook 4.2.1 XML documents (hereafter, DocBook documents). In addition, this document provides use cases to explain how content-contributors will perform specific tasks and operations.

This document applies to Content Creation .25 only.

1.2. Project Overview

Residing within ESG and the NonStop Enterprise Division (NED), the Enterprise Content Management (ECM) strategy and program seeks to ensure improved customer access to timely, relevant, and accurate technical content. The ECM program consists of these core projects:

- Content Creation (CC)
- Content Management (CM)
- Content Delivery (CD) (includes Content Publishing)

IPDS will release CC and CM deliverables incrementally, increasing functionality for each release.

1.3. Authoring Platform Overview

The CC .25 release of the authoring platform will consist of:

- XML authoring application
- DocBook XML DTD
- IPDS customized cascading style sheet for DocBook XML DTD
- IPDS XML authoring template for NED publications
- IPDS XML boilerplates

1.4. Assumptions and Dependencies

DEP #01-10. XMetaL Author can be configured as described in this specifications document.

DEP #01-20 (PRD Reqs #TR1-110, TR1-203, TR1-170). CM .25 drop folders will be available for the CC .25 release to generate review and final renditions from XML source content.

DEP #01-30. Content-contributors will be provided IPDS-specific instructions for using XMetaL for Authors.

1.5. Limitations and Design Constraints

LIM #01-10 (PRD Req #01-20). The DocBook 4.1.2 XML DTD shall be used as-is (out of the box).

LIM #01-20 (PRD Req #AT6-710-10). Modifications and augmentations to the standard transformations available from sourceforge.net shall be kept separate from the source code. This will allow migration to new versions of the standard transformations with minimal impact.

LIM #01-30 (PRD Section 2.5). XMetaL Author must satisfy requirements identified by the Content-Creation core team for the first release of the tool.

LIM #01-40 (PRD Goal #01-10, Reqs #ST1-10, ST1-30, ST1-50). XMetaL will be compatible with industry standards for structured authoring, data modeling, and transformations as described in recommendations, specifications, and guidelines located at http://www.w3c.org/.

LIM #01-50 (PRD Goal #01-30). Whenever possible, XMetaL will be configured, rather than customized, to satisfy identified requirements.

LIM #01-60 (PRD #DM1-150). XML authoring templates shall display only a subset of the available DocBook tags. The details of this subset are found in CC .25 Information Model.
1.6. Requirements Not Addressed

These CC .25 requirements are not specifically addressed in this specification. They will be addressed in CC .25 test plans.

Req #AT0-25 (Obj #09-25) The authoring application shall not introduce errors when a midaction outage occurs.

Req #AT0-25-30 (Obj #09-25) The authoring application shall ensure well-formed content if an outage occurs while the content-contributor is creating, deleting, and editing a DocBook document. When the authoring application is restarted, it shall either complete the action immediately or back it out.

Req #AT0-25-40 (Obj #09-25) The authoring application shall not skip validation if an outage occurs while the content-contributor is creating, deleting, and editing a DocBook document. When the authoring application is restarted, it shall either complete the action immediately or back it out.

Req #AT1-203-30 (Obj #01-01) Authoring application shall allow data-model choices to be added and deleted as business processes change.

Req #DT1-10 (Obj #18-10) Authoring application shall have a task-oriented online help system.

1.7. Reference Documents

<table>
<thead>
<tr>
<th>Document Name</th>
<th>Version</th>
<th>Date</th>
<th>Owners</th>
<th>Location</th>
</tr>
</thead>
</table>

1.8. User Description

<table>
<thead>
<tr>
<th>UC Number</th>
<th>Operational Role</th>
<th>User Characteristic</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>Content-contributor</td>
<td>Content-contributors who author NED technical publications and reviewers and editors and managers who review and approve content through formal business processes. Content-contributors are either onsite workers or remote teleworkers.</td>
</tr>
</tbody>
</table>
2. XML Authoring Application

2.1. Description

XMetaL 4 Author is the selected XML authoring application (editor). It allows content-contributors to create and edit XML content. XMetaL Author features authoring aids and the construct support necessary to create valid and well-formed DocBook documents.

The XMetaL user interface ("workspace") includes configurable window management, customizable toolbars, and tear-off menus. These workspace items will be configured to create a consistent and supportable interface:

- Menus
- Toolbars
- Main document pane with different editing views
- Structure View pane
- Context bar
- Attribute Inspector pane
- Element List pane
- Options dialog box
- Resource/Asset Manager
- Revision Mark Options dialog box

When content-contributors exit XMetaL 4 Author, their current workspace settings are automatically saved for their next session.

2.2. Menus

2.2.1. Description

The out-of-the-box version of XMetaL includes eight menus. Each menu contains multiple commands. The tables that follow specify how XMetaL menus must be configured for the CC .25 authoring platform:

- An asterisk (*) indicates a custom command (that is, a new command added by IPDS and not provided in the out-of-the-box XMetaL application).
- The Include column indicates which menu commands should be available to content-contributors.
- The Remove column indicates which menu commands should be unavailable to content-contributors.

2.2.2. File Menu Configuration

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close All</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save As</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save All</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Preview in Browser</td>
<td>x</td>
<td></td>
<td>Content-contributors will use the Browser Preview command instead.</td>
</tr>
<tr>
<td>Workspace</td>
<td></td>
<td>x</td>
<td>To ensure consistency, content-contributors will not be able to modify the workspace.</td>
</tr>
<tr>
<td>Print</td>
<td>x</td>
<td></td>
<td>Printing supported in Tags On, Normal, and Browser Preview modes. Normal printing based on CSS; Page Preview printing based on XSLT.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>x</td>
<td></td>
<td>Only available in Browser Preview mode; grayed out in other view modes.</td>
</tr>
<tr>
<td>Exit</td>
<td>x</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## 2.2.3. Edit Menu Configuration

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Copy</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Paste</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select Element</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change Element</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove Tags</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Join Element to Preceding</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Split Element</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find and Replace</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Find Next</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>*Find Attribute</td>
<td>x</td>
<td></td>
<td>Allows content-contributors to find and replace attributes and attribute values.</td>
</tr>
</tbody>
</table>

## 2.2.4. View Menu Configuration

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plain Text</td>
<td>x</td>
<td></td>
<td>To avoid changes to XML that invalidate the structure, plain text view will be unavailable.</td>
</tr>
<tr>
<td>Tags On</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Normal</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Browser Preview</td>
<td>x</td>
<td></td>
<td>Same as Preview in Browser. Launches an IE session and uses IPDS CSS to display document.</td>
</tr>
<tr>
<td>Hide Inline Images</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Hide Table Grid</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Structure View</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Attribute Inspector</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Element List</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Validation Log</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toolbars</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Status Bar</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Full Screen</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Workbook Mode</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resource Manager</td>
<td>x</td>
<td></td>
<td>To be supported for CC .5 or later when a CMS is available.</td>
</tr>
<tr>
<td>*Increase Font</td>
<td>x</td>
<td></td>
<td>Increases the font size of the DocBook document in the main document pane. Command is grayed out if font is already at maximum size.</td>
</tr>
<tr>
<td>*Decrease Font</td>
<td>x</td>
<td></td>
<td>Decreases the font size of the DocBook document in the main document pane. Command is grayed out if font is already at minimum size.</td>
</tr>
</tbody>
</table>

## 2.2.5. Insert Menu Configuration

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Entity Reference</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CDATA Section</td>
<td>x</td>
<td></td>
<td>Inserts XMetaL-specific processing instructions. Content-contributors should use special characters/symbols to insert program code (for example, &lt; or &gt;).</td>
</tr>
<tr>
<td>Comment</td>
<td></td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>
### Commands

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing Instruction</td>
<td></td>
<td>x</td>
<td>Content-contributors will not be able to create their own processing instructions (PIs). The only supported PIs are the custom Insert Comment to Writer command and the standard Tools&gt;Track Changes command.</td>
</tr>
<tr>
<td>Special Characters</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Symbols</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td><em>Image</em></td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Block</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inline</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>*Comment to Reviewer</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>*Comment to Writer</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td><em>Boilerplate</em></td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Glossary Entry</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Block Image</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Inline Image</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Event Message</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Numbered Message</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Unnumbered Message</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Legal Notice</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Partition</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Question+Answer</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Term+Definition</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link</td>
<td></td>
<td>x</td>
<td>Displays a dialog box that allows content-contributors to insert links to targets within the same document or on the WWW.</td>
</tr>
<tr>
<td>Link Target Anchor</td>
<td></td>
<td>x</td>
<td>Displays a dialog box that allows content-contributors to insert link anchors within the same document.</td>
</tr>
</tbody>
</table>

### 2.2.6. Tools Menu Configuration

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spell Checker</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thesaurus</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Macros</td>
<td></td>
<td>x</td>
<td>There is no requirement for user-created macros.</td>
</tr>
<tr>
<td>Record New Macros</td>
<td></td>
<td></td>
<td>There is no requirement for user-created macros.</td>
</tr>
<tr>
<td>Track Changes</td>
<td>x</td>
<td></td>
<td>Allows content-contributors to track changes to content. Transformed for review renditions only.</td>
</tr>
<tr>
<td>Accept or Reject Changes</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Revision Mark Options</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Text Entities</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>External Entities</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Graphic Entities</td>
<td></td>
<td>x</td>
<td>There is no requirement for creating graphic entities.</td>
</tr>
<tr>
<td>Validate Document</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Validate Selection</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Options</td>
<td>x</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Commands</td>
<td>Include</td>
<td>Remove</td>
<td>Comment/Rationale</td>
</tr>
<tr>
<td>------------------</td>
<td>---------</td>
<td>--------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>Customizations</td>
<td></td>
<td>x</td>
<td>No customizations of the workspace will be allowed.</td>
</tr>
<tr>
<td><em>Mark Changes</em></td>
<td></td>
<td></td>
<td>Inserts a &lt;revisionflag&gt; element, allowing content-</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>contributors to mark content as changed, added,</td>
</tr>
<tr>
<td>Changed</td>
<td></td>
<td></td>
<td>deleted, or off. Transformed for review and final</td>
</tr>
<tr>
<td>Added</td>
<td></td>
<td></td>
<td>renditions.</td>
</tr>
<tr>
<td>Deleted</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Off</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2.2.7. **Table Menu Configuration**

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Table</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Insert Caption</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Insert Rows or Columns</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Delete Row</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Delete Column</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Move Row or Column</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Merge Cell</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Split Cell Into Columns</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Split Cell Into Rows</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Table Properties</td>
<td></td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>

2.2.8. **Windows Menu Configuration**

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Previous</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Cascade</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Tile Horizontally</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Tile Vertically</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Arrange Icons</td>
<td></td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>

2.2.9. **Help Menu Configuration**

<table>
<thead>
<tr>
<th>Commands</th>
<th>Include</th>
<th>Remove</th>
<th>Comment/Rationale</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Search for Help On</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>How to Use Help</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Tip of the Day</td>
<td></td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Corel Home Page</td>
<td></td>
<td>x</td>
<td>Corel is no longer the owner of XMetaL.</td>
</tr>
<tr>
<td>About XMetaL Author</td>
<td></td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>
### 2.3. Toolbars

#### 2.3.1. Description

The out-of-the-box version of XMetaL includes 10 toolbars. The tables that follow specify how XMetaL toolbars must be configured for the CC .25 authoring platform:

- An asterisk (*) indicates a custom command (that is, a new command added by IPDS and not provided in the out-of-the-box XMetaL application).
- The Include Toolbar column indicates which toolbars should be available to content-contributors.
- The Display Toolbar First Time column indicates whether the toolbar should be displayed the first time a content-contributor launches XMetaL and opens a DocBook document that includes the IPDS doctype declaration.

**Note:** The display of a toolbar at the start of subsequent sessions depends on whether the content-contributor chooses to show or hide the toolbar before exiting the workspace.

- The Hide Toolbar column indicates which toolbars should not be unavailable to content-contributors.
- The Include Command column indicates which toolbar commands should be available to content-contributors.
- The Hide Command column indicates which toolbar commands should be hidden from content-contributors.

#### 2.3.2. Menu Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>x</td>
<td>N.A.</td>
<td>Not configurable</td>
<td>N.A.</td>
<td>N.A.</td>
</tr>
</tbody>
</table>

#### 2.3.3. Standard Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>x</td>
<td></td>
<td>Create New Doc</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Open Existing Doc</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Save Active Doc</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Save All Modified Docs</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Find + Replace</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Find Next</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Check Spelling</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Cut</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Copy</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Paste</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Undo</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Redo</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Insert Image¹</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>*Insert Anchor</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>*Insert Link Anchor</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Insert Table</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Insert Element</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Previous Window/Document</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Next Window/Document</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Validate Document x</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Help</td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>

¹ Inserts block image boilerplate.
### 2.3.4. Formatting Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td></td>
<td></td>
<td>Style Element</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Bold'</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Italic&quot;</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Underline&quot;</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Numbered List</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Bulleted List</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. Inserts `<emphasis>` element for bolding content.
2. Inserts `<replaceable>` element for italicizing content.
3. Only identified use for underlines in IPDS publications is link text.

### 2.3.5. Table Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td></td>
<td></td>
<td>Insert</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Edit Table Display Properties</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Insert Row Above Cursor</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Insert Row Below Cursor</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Delete Table Row</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Insert Column Left of Cursor</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Insert Column Right of Cursor</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Delete Table Column</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Move Row Up</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Move Row Down</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Move Column Left</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Move Column Right</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Merge With Cell Above</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Merge With Cell Below</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Merge With Cell to Right</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Merge With Cell to Left</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Split Cell Into 2 Rows</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Split Cell Into 2 Columns</td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>

### 2.3.6. Table Advanced Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td></td>
<td></td>
<td>Contract Cell From Left</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Contract Cell From Right</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Contract Cell From Above</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Contract Cell From Below</td>
<td>x</td>
<td></td>
</tr>
</tbody>
</table>

### 2.3.7. Macros Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>N.A.</td>
<td>N.A.</td>
<td></td>
<td>N.A.</td>
<td>N.A.</td>
</tr>
</tbody>
</table>

### 2.3.8. Preview Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>x</td>
<td>N.A.</td>
<td>N.A.</td>
<td></td>
<td>N.A.</td>
<td>N.A.</td>
</tr>
</tbody>
</table>
### 2.3.9. Views Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Plain Text†</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Tags On</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Normal</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Browser (Page) Preview</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Show Attribute Inspector</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Show Insert Element</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Resource Manager²</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Toggle Full Screen</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>*Increase Font</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>*Decrease Font</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

† To avoid changes to XML that invalidate the structure, plain text view will be unavailable.

² To be supported for CC .5 or later when a CMS is available.

### 2.3.10. Special Characters Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Default characters</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

### 2.3.11. Symbols Toolbar Configuration

<table>
<thead>
<tr>
<th>Include Toolbar</th>
<th>Display Toolbar First Time</th>
<th>Hide Toolbar</th>
<th>Toolbar Commands</th>
<th>Include Command</th>
<th>Hide Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>Default symbols</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>
2.4. **Main Document Pane**

2.4.1. **Description**
Open DocBook documents are displayed in the main document pane. Out-of-the-box, it supports editing in these three views:

- Normal View. Displays a document as it would appear in a word processor; that is, without visible XML markup. Automatic rules checking, which ensures adherence to the DTD, is turned on by default. Display is controlled by a cascading style sheet (CSS).
- Tags On View. Displays a document with some XML markup (that is, element start and end tags). Automatic rules checking, which ensures adherence to the DTD, is turned on by default. Display is controlled by a CSS.
- Plain Text View. Shows all XML markup, including doctype and entity declarations. No content formatting or validation is available.

**Note:** Plain Text view will not be supported for the CC .25 release because of the high risk that content-contributors will create invalid DocBook documents.

Out of the box, the main document pane also supports Page Preview, which displays content as it would appear in a browser. Editing is not supported in this view.

2.4.2. **Configuration**

2.4.2.1. By default, the Tags On view will be displayed the first time a content-contributor opens a DocBook document with the IPDS doctype declaration. For a description of the declaration, see the CC .25 Information Model.

2.4.2.2. To select a different editing view, content-contributors will select **View>Normal**.

**Note:** Content-contributors must be able to select a different editing view without reassigning a DTD.

2.4.2.3. The appearance of content in the main document pane will be controlled by a customized CSS. See [Cascading Style Sheet for DocBook XML DTD](#) for more information.

2.4.2.4. A customized Browser Preview command, listed under the View menu, will replace Page Preview.

2.5. **Structure View Pane**

2.5.1. **Description**
The structure view, which is a pane to the left of the main document pane, displays the outline of the document. Block elements are displayed one per line and indented to indicate their nesting level. The appearance of the structured view pane is controlled by a customized CSS.

2.5.2. **Configuration**

2.5.2.1. By default, the structure view pane will not be displayed the first time a content-contributor opens a DocBook document with the IPDS doctype declaration. For a description of the declaration, see the CC .25 Information Model.

2.5.2.2. To display the structure view pane, content-contributors will select **View>Structure View**.

2.6. **Context Bar**

2.6.1. **Description**
The context bar, which is located below the main document pane, identifies which element you are editing in Normal or Tags On view. The context bar displays the name of the current element preceded by its parents to the top-level element.

2.6.2. **Configuration**

By default, the context bar will be displayed.
2.7. Attribute Inspector Pane

2.7.1. Description
The Attribute Inspector allows content-contributors to edit the attributes of elements.

2.7.2. Configuration
2.7.2.1. By default, the Attribute Inspector pane will not be displayed the first time a content-contributor opens a DocBook document with the IPDS doctype declaration. For a description of the declaration, see the CC .25 Information Model.

2.7.2.2. To display the Attribute Inspector pane, content-contributors will select View>Attribute Inspector.

2.8. Element List Pane

2.8.1. Description
The Element List allows content-contributors to insert or change an element in the DocBook document.

The Element List pane includes two tabs: Used and All. The Used tab lists up to ten of the most frequently used elements that are valid in the current context. The All tab lists all elements that are valid in the current context. The Element List displays the next required element in the current context in boldface.

2.8.2. Configuration
2.8.2.1. By default, the Element List pane will be displayed the first time a content-contributor opens a DocBook document with the IPDS doctype declaration. For a description of the declaration, see the CC .25 Information Model.

2.8.2.2. To hide the Element List pane, content-contributors will select View>Element List.

2.8.2.3. The Element List pane will display only a subset of the available DocBook tags. The details of this subset are found in the CC .25 Information Model.

2.9. Options Dialog Box

2.9.1. Description
The Options dialog box allows content-contributors to specify general options, options that configure the main document pane, and file-related settings, including default template options.

2.9.2. Configuration

<table>
<thead>
<tr>
<th>Tab</th>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Current User&gt;Name</td>
<td>NT ID</td>
</tr>
<tr>
<td></td>
<td>Current User&gt;Initials</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Location to temporarily store remote files&gt;Folder</td>
<td>Out-of-box default</td>
</tr>
<tr>
<td>Miscellaneous&gt; Show tag tips</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>Miscellaneous&gt; Show icons in menus</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>Miscellaneous&gt; Restore last open documents</td>
<td>On</td>
<td></td>
</tr>
<tr>
<td>View</td>
<td>Open new documents in</td>
<td>Tags On view</td>
</tr>
<tr>
<td></td>
<td>Show inline images</td>
<td>Selected</td>
</tr>
<tr>
<td></td>
<td>Show comments</td>
<td>Selected</td>
</tr>
<tr>
<td></td>
<td>Show Structure View by default</td>
<td>Deselected</td>
</tr>
<tr>
<td></td>
<td>Tag Icons&gt;Font</td>
<td>Arial</td>
</tr>
<tr>
<td></td>
<td>Tag Icons&gt;Size</td>
<td>8 pt</td>
</tr>
<tr>
<td></td>
<td>Tag Icons&gt;Foreground</td>
<td>Out-of-box default</td>
</tr>
<tr>
<td></td>
<td>Tag Icons&gt;Background</td>
<td>Out-of-box default</td>
</tr>
<tr>
<td></td>
<td>Tag Icons&gt;Minimize Tag Icons</td>
<td>Deselected</td>
</tr>
</tbody>
</table>
The Options dialog box cannot be configured to hide individual tabs. Consequently, Plain Text view options will remain visible in the Options dialog even though Plain Text view is not supported in the IPDS-configured workspace.

2.10. Resource Manager Pane

2.10.1. Description

The Resource Manager is a file management tool. It provides drag-and-drop management of boilerplate text, document fragments, and other content assets, both locally and across a network.

2.10.2. Configuration

The Resource Manager pane will be hidden (that is, not available to content-contributors).

Note: The Resource Manager, which is designed primarily for use with a CMS, will be supported for CC .5 or later when a CMS is available.

2.11. Revision Mark Options dialog box

2.11.1. Description

Using the Revision Mark Options dialog box, content-contributors can specify how inserted or deleted content appears on the screen. Revision marking is controlled by the Tools>Track Changes command, which inserts DTD-neutral processing instructions into the XML source code. Revision marking is not transformed for review or final renditions.

Note: Unlike the Tools>Track Changes command, the Tools>Mark Changes command inserts the <revisionflag> element. <revisionflag> markings are transformed for review and final renditions.
2.11.2. Configuration

2.11.2.1. By default, the change tracking feature is turned off. To activate the feature, select **Tools>Track Changes**.

2.11.2.2. Out-of-the-box settings for the Revision Mark Options dialog box will be displayed the first time a content-contributor opens a DocBook document with the IPDS doctype declaration. For a description of the declaration, see the CC .25 Information Model.
3. DocBook XML DTD

3.1. Description

The CC .25 release of the authoring platform will use the DocBook 4.1.2 XML DTD, a standard, off-the-shelf data model intended for technical publications. No direct customizations of the DTD will be supported.

3.2. Supported Elements

A subset of DocBook DTD elements will be displayed for content-contributors; all other elements will be hidden from the workspace. For details about this subset, see the CC .25 Information Model.

3.3. Required and Optional Attributes

A subset of DocBook DTD attributes and values will be displayed for content-contributors; all others will be hidden from the workspace. In addition, the use of some attributes will be required; others will be optional. For details about this subset, see the CC .25 Information Model.

3.4. Required Child Elements

Specific child elements must be automatically inserted when their parent elements are inserted. For details about these parent/child relationships, see the CC .25 Information Model.

3.5. Doctype Declaration

DocBook documents created by IPDS content-contributors must include a unique doctype declaration that identifies the governing IPDS DTD. For details about the DTD and the doctype declaration, see the CC .25 Information Model.
4. IPDS Cascading Style Sheet for DocBook XML DTD

4.1. Description

The CC .25 release of the authoring platform will include a customized cascading style sheet (CSS) to control and standardize the appearance of content in XMetaL’s main document pane. The CSS will be compatible with the DocBook 4.1.2 XML DTD.

4.2. Configuration

The $DOCUMENT section at the top level of the cascading style sheet (CSS) defines parent elements and their characteristics. By default, most elements inherit the properties of their parents. Attribute values for CSS properties are usually set to the default, which creates the inheritance relationship. As a result, each time an element is added to the subset of supported DocBook DTD elements, it will be automatically rendered in XMetaL.

Other sections in the CSS define exceptions to the properties in the $DOCUMENT section.

4.2.1. $DOCUMENT Styles

<table>
<thead>
<tr>
<th>Properties</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>font-family</td>
<td>Verdana, Arial, sans-serif</td>
</tr>
<tr>
<td>color</td>
<td>#000000</td>
</tr>
<tr>
<td>background-color</td>
<td>#FFFFFF</td>
</tr>
<tr>
<td>font-size</td>
<td>12pt</td>
</tr>
<tr>
<td>font-weight</td>
<td>normal</td>
</tr>
<tr>
<td>margin-top</td>
<td>6pt</td>
</tr>
<tr>
<td>margin-left</td>
<td>4pt</td>
</tr>
<tr>
<td>margin-bottom</td>
<td>16pt</td>
</tr>
<tr>
<td>padding-top</td>
<td>6pt</td>
</tr>
<tr>
<td>padding-left</td>
<td>4pt</td>
</tr>
<tr>
<td>text-align</td>
<td>left</td>
</tr>
<tr>
<td>display</td>
<td>block</td>
</tr>
</tbody>
</table>

4.2.2. Heading Styles

<table>
<thead>
<tr>
<th>Element</th>
<th>Characteristics</th>
<th>Properties</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>abstract&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>appendix&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>book&gt;title</td>
<td>font-size: 30pt</td>
<td></td>
<td></td>
</tr>
<tr>
<td>chapter&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>example&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>figure&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>formalpara&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>glossary&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>legal notices&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>qandadiv&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>part&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td>preface&gt;title</td>
<td>font-weight: bold</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>font-size: 28pt</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

|                     | font-size: 13pt          |            |        |
|                     | font-size: 28pt          |            |        |
### 4.2.3. Inline Styles

<table>
<thead>
<tr>
<th>Element</th>
<th>Characteristics</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Properties</td>
</tr>
<tr>
<td>sect1&gt;title</td>
<td>font-weight</td>
</tr>
<tr>
<td></td>
<td>font-size</td>
</tr>
<tr>
<td>sect2&gt;title</td>
<td>font-weight</td>
</tr>
<tr>
<td></td>
<td>font-size</td>
</tr>
<tr>
<td>sect3&gt;title</td>
<td>font-weight</td>
</tr>
<tr>
<td></td>
<td>font-size</td>
</tr>
<tr>
<td>sect4&gt;title</td>
<td>font-weight</td>
</tr>
<tr>
<td></td>
<td>font-size</td>
</tr>
<tr>
<td>set&gt;title</td>
<td>font-size</td>
</tr>
<tr>
<td></td>
<td>font-weight</td>
</tr>
<tr>
<td>table&gt;title</td>
<td>font-weight</td>
</tr>
</tbody>
</table>

### 4.2.4. Table Styles

<table>
<thead>
<tr>
<th>Element</th>
<th>Characteristics</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Properties</td>
</tr>
<tr>
<td>thead</td>
<td>font-weight</td>
</tr>
<tr>
<td></td>
<td>font-size</td>
</tr>
</tbody>
</table>

---

Data from Table 1 (continued): Properties (continued)
### 4.2.5. Revision Styles

<table>
<thead>
<tr>
<th>Element/Processing Instruction</th>
<th>Characteristics</th>
</tr>
</thead>
<tbody>
<tr>
<td>font-family</td>
<td>Courier, monospaced</td>
</tr>
<tr>
<td>color</td>
<td>red</td>
</tr>
<tr>
<td>font-size</td>
<td>12pt</td>
</tr>
</tbody>
</table>

- **remark (Comment to Reviewer)**
  - font-family: Courier, monospaced
  - font-weight: italics; bold
  - font-size: 12pt
  - color: red

- **revisionflag=changed**
  - background-color: gray

- **revisionflag=added**
  - background-color: gray

- **revisionflag=deleted**
  - font-weight: strikethrough

### 4.2.6. :before Styles

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Characteristics</th>
</tr>
</thead>
<tbody>
<tr>
<td>id</td>
<td>font-size: 10pt</td>
</tr>
<tr>
<td></td>
<td>color: blue</td>
</tr>
<tr>
<td>other</td>
<td>surrounding brackets</td>
</tr>
</tbody>
</table>

- **arch**
  - font-size: 10pt
  - color: blue
  - other: surrounding brackets

- **condition**
  - font-size: 10pt
  - color: blue
  - other: surrounding brackets

- **id**
  - font-size: 10pt
  - color: blue
  - other: surrounding brackets

- **os**
  - font-size: 10pt
  - color: blue
  - other: surrounding brackets

- **revisionflag**
  - font-size: 10pt
  - color: blue
  - other: surrounding brackets

### 4.2.7. Other Styles

<table>
<thead>
<tr>
<th>Element</th>
<th>Characteristics</th>
</tr>
</thead>
<tbody>
<tr>
<td>caution</td>
<td>font-size: 11pt</td>
</tr>
<tr>
<td>footnote</td>
<td>font-size: 10pt</td>
</tr>
<tr>
<td>literallayout</td>
<td>font-family: Courier, monospaced</td>
</tr>
<tr>
<td></td>
<td>font-size: 11pt</td>
</tr>
<tr>
<td>note</td>
<td>font-size: 11pt</td>
</tr>
<tr>
<td>term</td>
<td>font-weight: bold</td>
</tr>
<tr>
<td>warning</td>
<td>font-size: 11pt</td>
</tr>
</tbody>
</table>
5. IPDS XML Authoring Template

5.1. Description

The IPDS XML authoring template is an editable, DocBook-based XML file. IPDS content-contributors will use it to create publication renditions in either HTML or HTML Help format. Customized transformations will generate the required HTML or HTML Help rendition. The template will:

- Include the IPDS doctype declaration. For a description of the declaration, see the CC .25 Information Model.
- Include high-level elements defining the basic components of a publication in a specific order.
- Include dummy text that directs content-contributors where to insert content.
- Control the appearance and settings of the XMetaL workspace.
- Be stored in a template directory and locked so that they cannot be overwritten in a Save operation.

5.2. Content and Structured Markup

```xml
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE book PUBLIC "-//HP//DTD DocBook XML V4.1.2-Based Extension NED-InfoModel V1.0//EN" "infomodel_v1.dtd">
<book>
  <title>enter_publication_title_here</title>
  <bookinfo>
    <title>Version and Copyright Information</title>
    <abstract>
      <title>Abstract</title>
      <para>enter_abstract_here</para>
    </abstract>
    <para>To order a copy of this manual, use this part number:
      <invpartnumber>enter_partnumber_here</invpartnumber></para>
  </bookinfo>
  <productname>enter_product_name_here</productname>
  <productnumber>enter_product_number_here</productnumber>
  <releaseinfo>enter_release_statement_here</releaseinfo>
  <!-- Delete Legal Notices link if not needed -->
  <legalnotices>
    <title>Legal Notices</title>
    <para>insert_legal_notices Boilerplate here</para>
  </legalnotices>
  <pubsnumber>enter_document_ID_here</pubsnumber>
  <revhistory>
    <revision>
      <revnumber>enter_document_version_number_here</revnumber>
      <date condition="hidden">this date field is hidden in renditions</date>
    </revision>
  </revhistory>
  <pubdate>enter_published_date_here</pubdate>
  <!-- The What’s New section is optional for online help systems -->
  <preface>
    <title>What’s New in This Guide</title>
  </preface>
  <!-- The About This Guide section is optional for online help systems -->
  <preface>
    <title>About This Guide</title>
    <para>describe_guide_here</para>
  </preface>
  <sect1>
    <title>Who Should Read This Guide</title>
  </sect1>
  <sect1>
    <title>Related Reading</title>
  </sect1>
</book>
```
<sect1>
<title>Notation Conventions</title>
</sect1>

<!-- An appendix is optional for online help systems -->
<appendix>
<title>enter_appendix_or_topic_title_here</title>
<sect1>
<title>enter_level_1_heading_here</title>
</sect1>
</appendix>

<!-- Delete glossary elements if no glossary -->
<!-- Glossary is optional for online help systems -->
<glossary>
<title>Glossary</title>
<para><link linkend="A">A</link></para>
<para><link linkend="Z">Z</link></para>
<glossdiv>
<title><anchor id="A">A</anchor></title>
<para>There are no entries for this section</para>
</glossentry>
</glossdiv>
<glossdiv>
<title><anchor id="Z">Z</anchor></title>
<para>There are no entries for this section</para>
</glossentry>
</glossdiv>
</glossary>

<!-- Delete index elements if no index -->
</index>
</book>
6. IPDS XML Boilerplates

6.1. Description

IPDS XML boilerplates are commonly used, but relatively complex, structures that contain dummy text and surrounding XML markup. Instead of creating a structure each time one is needed, content-contributors will copy it from a boilerplate to their DocBook document.

Currently identified boilerplates are:

- Glossary entry
- Image (block)
- Image (inline)
- Legal notices
- Event message
- Numbered message
- Unnumbered message
- Partition (part)
- Question and answer pair
- Term and definition pair

6.2. Glossary Entry Boilerplate

6.2.1. Description

A content-contributor uses this boilerplate to insert a paired term and definition in a publication’s glossary.

6.2.2. Dummy Text and Markup

```xml
<glossentry>
  <glossterm>enter_term_here</glossterm>
  <glossdef>
    <para>enter_definition_here</para>
  </glossdef>
</glossentry>
```

6.3. Image (Block) Boilerplate

6.3.1. Description

A content-contributor uses this boilerplate to insert an image with a paragraph (or larger) break before and after the surrounding markup. This boilerplate does not include a heading. The content-contributor first inserts a `<figure>`, `<informalfigure>`, `<screenshot>`, `<example>`, or `<informalexample>` element and then nests this boilerplate within it.

6.3.2. Dummy Text and Markup

```xml
<mediaobject>
  <imageobject>
    <imagedata>click_here_to_insert_image</imagedata>
  </imageobject>
  <textobject>
    <phrase>enter_required_alternative_text_here</phrase>
  </textobject>
  <caption>
    <para>enter_caption_or_delete_this_tag_set</para>
  </caption>
</mediaobject>
```
6.4. Image (Inline) Boilerplate

6.4.1. Description
A content-contributor uses this boilerplate to insert an inline image. This boilerplate, which does not include a heading, is typically inserted within a <para> element.

6.4.2. Dummy Text and Markup

```xml
<inlinemediaobject>
  <imageobject>
    <imagedata>click_here_to_insert_image</imagedata>
  </imageobject>
  <textobject>
    <phrase>enter_required_alternative_text_here</phrase>
  </textobject>
</inlinemediaobject>
```

6.5. Legal Notices Boilerplate

6.5.1. Description
A content-contributor uses this boilerplate in printed manuals, online help systems, and Independent Product (IP) documentation. This boilerplate is inserted within opening and closing <legalnotice> elements (after the <title> element). This boilerplate should be locked (read-only).

6.5.2. Standard Text and Markup

```xml
<para>&copy; Copyright 2004 Hewlett-Packard Development Company L.P. </para>
<para>Confidential computer software. Valid license from HP required for possession, use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard commercial license.</para>
<para>The information contained herein is subject to change without notice. The only warranties for HP products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.</para>
<para>Export of the information contained in this publication may require authorization from the U.S. Department of Commerce.</para>
<para>Microsoft, Windows, and Windows NT are U.S. registered trademarks of Microsoft Corporation.</para>
<para>Intel, Pentium, and Celeron are trademarks or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.</para>
<para>Java is a U.S. trademark of Sun Microsystems, Inc.</para>
<para>Motif, OSF/1, UNIX, X/Open, and the "X" device are registered trademarks, and IT Dial Tone and The Open Group are trademarks of The Open Group in the U.S. and other countries.</para>
<para>Open Software Foundation, OSF, the OSF logo, OSF/1, OSF/Motif, and Motif are trademarks of the Open Software Foundation, Inc.</para>

<simplelist>
  <member>OSF MAKES NO WARRANTY OF ANY KIND WITH REGARD TO THE OSF MATERIAL PROVIDED HEREIN, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.</member>
  <member>OSF shall not be liable for errors contained herein or for incidental consequential damages in connection with the furnishing, performance, or use of this material.</member>
  <member>&copy; 1990, 1991, 1992, 1993 Open Software Foundation, Inc. The OSF documentation and the OSF software to which it relates are derived in part from materials supplied by the following:</member>
</simplelist>
```
6.6. Numbered Message Boilerplate

6.6.1. Description

A content-contributor uses this boilerplate to insert numbered message information. Cause, effect, and recovery paragraphs follow the message. Content-contributor first inserts the parent <msgset> element and then nests this boilerplate within it. Unneeded child elements can be deleted from the boilerplate.

6.6.2. Dummy Text and Markup

<msgentry>
  <msg>
    <msgmain>
      <title>
        <errorcode>enter_errorcode_here</errorcode>
        <errorname>enter_errorname_here</errorname>
      </title>
      <msgtext>
        <literallayout>
          <literal>enter_message_text_here</literal>
          <replaceable>enter_variable_here</replaceable>
        </literallayout>
      </msgtext>
      <!-- Delete msginfo elements if no severity or origination info -->
      <msginfo>
        <msglevel>enter_severity_here_or_delete</msglevel>
        <msgorig>enter_error_source_here_or_delete</msgorig>
      </msginfo>
      <msgexplan>
        <variablelist>
          <varlistentry>
            <term>
              <literal>enter_term_here_or_delete</literal>
              <replaceable>enter_variable_here_or_delete</replaceable>
            </term>
            <listitem>
              <para>enter_description_here_or_delete</para>
            </listitem>
          </varlistentry>
        </variablelist>
        <formalpara>
          <title>Cause</title>
          <para>enter_cause_text_here</para>
        </formalpara>
      </msgexplan>
    </msgmain>
  </msg>
</msgentry>
6.7. Unnumbered Message Boilerplate

6.7.1. Description

A content-contributor uses this boilerplate to insert unnumbered message information. Cause, effect, and recovery paragraphs follow the message. Content-contributor inserts the parent <msgset> element and nests the contents of this boilerplate within it. Unneeded child elements can be deleted from the boilerplate.

6.7.2. Dummy Text and Markup

<simplemsgentry>
<msgtext>
<literallayout>
<literal>enter_message_text_here</literal>
<replaceable>enter_variable_here</replaceable>
</literal>
</literallayout>
</msgtext>
<msgexplan>
<!-- Delete unneeded severity or origination elements -->
<para>
<errorcode>enter_errorcode_here</errorcode>
<errorname>enter_errorname_here</errorname>
</para>
</variablelist>
</varlistentry>
</variablelist>
</msgexplan>
</msgentry>
</msgset>
6.8. Event Message Boilerplate

6.8.1. Description

A content-contributor uses this boilerplate to insert event message information. Cause, effect, and recovery paragraphs follow the message. Content-contributor inserts the parent <msgset> element and nests the contents of this boilerplate within it. Unneeded child elements can be deleted from the boilerplate.
### 6.8.2. Dummy Text and Markup

```xml
<msgentry>
  <msg>
    <msgmain>
      <msgtext>
        <para>enter_introductory_text_here_or_delete</para>
        <informaltable>
          <tgroup cols="2">
            <colspec colnum="1" colname="col1" colwidth="*"/>
            <colspec colnum="2" colname="col2" colwidth="*"/>
          </tgroup>
          <tbody>
            <row>
              <entry colname="col1">Subject:</entry>
              <entry colname="col2">enter_token_here</entry>
            </row>
            <row>
              <entry colname="col1">Potentially critical event:</entry>
              <entry colname="col2">enter_Yes_or_No</entry>
            </row>
            <row>
              <entry colname="col1">Action-attention event:</entry>
              <entry colname="col2">enter_Yes_or_No</entry>
            </row>
            <row>
              <entry colname="col1">Message sender:</entry>
              <entry colname="col2">enter_message_sender</entry>
            </row>
            <row>
              <entry colname="col1">TMDS collector:</entry>
              <entry colname="col2">enter_Yes_or_No</entry>
            </row>
          </tbody>
        </informaltable>
        <informaltable>
          <tgroup cols="2">
            <colspec colnum="1" colname="col1" colwidth="*"/>
            <colspec colnum="2" colname="col2" colwidth="*"/>
          </tgroup>
          <tbody>
            <row>
              <entry namestart="col1" nameend="col2">Unconditional Tokens</entry>
            </row>
            <row>
              <entry colname="col1">enter_token_name_here</entry>
              <entry colname="col2">token-type enter_token_type_here</entry>
            </row>
            <row>
              <entry colname="col1">enter_token_name_here</entry>
              <entry colname="col2">token-type enter_token_type_here</entry>
            </row>
            <row>
              <entry colname="col1">enter_token_name_here</entry>
              <entry colname="col2">token-type enter_token_type_here</entry>
            </row>
          </tbody>
        </informaltable>
      </msgtext>
    </msgmain>
  </msg>
</msgentry>
```
<row>
<entry namest="col1" nameend="col2"><emphasis>Event-Message Text</emphasis></entry>
</row>
<row>
<entry namest="col1" nameend="col2"><literal>enter_message_text_here</literal></entry>
</row>
<row>
<entry namest="col1" nameend="col2"><literal>enter_message_text_here</literal></entry>
</row>
</tbody>
</tgroup>
</informaltable>
</msgtext>
</msgmain>
</msg>
</msgexplan>
<title>Unconditional Tokens</title>
<informaltable>
tgroup cols="2">
<colspec colnum="1" colname="col1" colwidth="*"/>
<colspec colnum="2" colname="col2" colwidth="*"/>
<thead>
<row>
<entry colname="col1">Token</entry>
<entry colname="col2">Description</entry>
</row>
</thead>
<tbody>
<row>
<entry colname="col1">enter_token_name_here</entry>
<entry colname="col2">enter_description_here</entry>
</row>
<row>
<entry colname="col1">enter_token_name_here</entry>
<entry colname="col2">enter_description_here</entry>
</row>
</tbody>
</tgroup>
</informaltable>
<note><para>enter_note_text_here_or_delete</para></note>
<formalpara>
<title>Cause</title>
<para><?xm-replace_text enter_cause_text_here?></para>
</formalpara>
<para>
<itemizedlist>
</itemizedlist>
</para>
<formalpara>
<title>Effect</title>
<para><?xm-replace_text enter_effect_text_here?></para>
</formalpara>
<para>
<itemizedlist>
</itemizedlist>
</para>
6.9. **Partition Boilerplate**

6.9.1. **Description**

A content contributor uses this boilerplate to divide a manual into logically grouped sections. A partition typically identifies what's common among the sections in the partition, describes each section, and includes a mini-table of contents.

6.9.2. **Dummy Text and Markup**

```xml
<part>
  <title>enter_partition_title_here</title>
  <partintro>
    <para>describe_contents_of_partition_here</para>
  </partintro>
</part>
```

6.10. **Question and Answer Pair Boilerplate**

6.10.1. **Description**

A content-contributor uses this boilerplate in frequently asked questions (FAQ) documents. The content-contributor first inserts the parent `<qandaset>` element. The `<qadadiv>` and `<title>` child elements are automatically inserted with the parent.

6.10.2. **Dummy Text and Markup**

```xml
<qandaentry>
  <question>
    <para>enter_question_here</para>
  </question>
  <answer>
    <para>enter_answer_here</para>
  </answer>
</qandaentry>
```

6.11. **Term and Definition Boilerplate**

6.11.1. **Description**

A content-contributor might use this boilerplate for syntax terms and definitions and notation conventions.
6.11.2. Dummy Text and Markup

<variablelist>
   <varlistentry>
      <term>enter_syntax_term_here</term>
      <listitem>
         <para>enter_syntax_definition_here</para>
      </listitem>
   </varlistentry>
</variablelist>
7. **Use Cases**

7.1. **Install the Authoring Platform**

7.1.1. **Description**

Remote and local content-contributors must be able to install and update the IPDS Authoring Platform on their computers.

**Note:** XMetaL opens with out-of-the-box settings each time it is launched. After the IPDS Authoring Template or a DocBook document with the IPDS doctype declaration is opened, the workspace will be automatically reconfigured as described in XML Authoring Application.

Installation installs these authoring platform components on the content-contributor’s computer:

- XMetaL 4 Author application
- C:\Program Files\Corel\XMetaL 4\Author\xmetal4.ini file
- C:\Program Files\Corel\XMetaL 4\Author\Template\IPDS\Book.xml file
- C:\Program Files\Corel\XMetaL 4\Author\Rules\infomodel_v1.xac file, which contains:
  - Compiled DTD-related (.rlx) files
  - Boilerplate (.bp) files
  - Custom forms
  - Custom macro file
  - Toolbar (.tbr) file
  - Customization file
  - CSS files for main document and structured view panes
- C:\Program Files\Corel\XMetaL 4\Author\Display\infomodel_v1_HTML.xsl file, which is a pointer to the folder containing xsl files
- C:\Program Files\Corel\XMetaL 4\Author\Display\docbook-xsl-1.65.1, which contains xsl files

7.1.2. **Use Cases**

**UC 10-10.** Install the IPDS Authoring Platform. 
1. Verify that there is at least 120 MB of free disk space is available on the target installation drive.
2. Insert the XMetaL CD containing the IPDS Authoring Platform into a computer, and run the IPDS Authoring Platform installer.
3. Complete the installation by following the installer’s onscreen instructions. When prompted:
   - Select the Install XMetaL Author With Service Pack 4 option.
   - Select the XMetaL Customizations Installed Now by Setup option.
   - Select the Typical installation option.
4. Launch the XMetaL application.

**UC 10-20.** Update the XMetaL 4 Author application.
1. Same as UC 10-10.

**UC 10-30.** Update the IPDS Authoring Template.
1. Verify that the XMetaL application is closed.
2. Establish a network connection, and download the updated IPDS Authoring Template (Book.xml) from a specified network location.
3. Navigate to the C:\Program Files\Corel\XMetaL 4\Template\IPDS directory.
4. Copy Book.xml to the directory.
5. When prompted to overwrite the existing file, select OK.
6. Exit the directory.
7. Launch the XMetaL application.

**UC 10-40.** Update the xmetal4.ini file.
1. Verify that the XMetaL application is closed.
2. Establish a network connection, and download the updated xmetal4.ini file from a network location.
3. Navigate to the C:\Program Files\Corel\XMetaL 4\Author directory.
4. Rename the existing xmetal4.ini file to xmetal4_old.ini file.
5. Copy the updated xmetal4.ini file to the directory.
6. Exit the directory.
7. Launch the XMetaL application.

UC 10-50. Update any files contained in the XAC file.
1. Verify that the XMetaL application is closed.
2. Establish a network connection, and download the updated XAC file from a network location.
3. Navigate to the C:\Program Files\Corel\XMetaL 4\Author\Rules directory.
4. Copy the updated XAC file to the directory.
5. When prompted to overwrite the existing file, select OK.
6. Exit the directory.
7. Launch the XMetaL application.

7.1.3. **Constraints**

7.1.3.1. The installation computer must be a corporate standard Microsoft Windows workstation.
7.1.3.2. A network connection is required to download authoring platform component updates.

7.1.4. **Related PRD Requirement(s)**

Req #MN1-10, Req #MN1-10-10, Req #MN1-10-20, Req #MN1-10-30, Req #ST1-10, Req #ST1-30,
Req #ST1-50, Req #CC1-30, Req #CC1-40
7.2. Open an Existing DocBook or Other XML Document

7.2.1. Description

Using the XMetaL application, content-contributors must be able to open XML-based documents governed by any DTD and located on their local hard drives or network-connected drives.

7.2.2. Use Cases

UC 20-10. Open a DocBook document created with the IPDS authoring template.
1. Launch the XMetaL application.
2. Select File>Open (Ctrl+O). The Select Files to Open dialog box appears.
3. Navigate to the DocBook document's location as needed. Possible locations are:
   - Folder on the content contributor's local hard drive
   - Folder on a network-connected drive
   - The selected document opens in the XMetaL main document pane.
   - The DocBook DTD and CSS files installed with the IPDS authoring platform are automatically associated with the file.

Alternative
1. Launch the XMetaL application.
2. Select a recently opened document from the File menu.
   - The selected document opens in the XMetaL main document pane.
   - The DocBook DTD and CSS installed with the IPDS authoring platform are automatically associated with the file.

UC 20-20. Open an XML-based document not created with the IPDS authoring template.
1. Launch the XMetaL application.
2. Select File>Open (Ctrl+O). The Select Files to Open dialog box appears.
3. Navigate to the XML document's location as needed. Possible locations are:
   - Folder on the content contributor's local hard drive
   - Folder on a network-connected drive
4. Select the XML document, and click Open. XMetaL reads the doctype declaration in the XML document to identify the governing DTD.
   - If XMetaL can automatically locate the governing DTD, the selected document opens in the main document pane.
   - If XMetaL cannot automatically locate the governing DTD, it prompts the content-contributor to navigate to the DTD and select it. The XML document opens in the main document pane.

Note: The governing DTD must be in the same folder as the XML document or in C:\Program Files\Corel\XMetaL4\Author\Rules.

UC 20-30. Open an XML-based document created in Epic Editor.
1. Change any unsupported elements in the XML document:
   a. Obtain a copy of the CC .25 Information Model from the DMF.
   b. In Epic Editor, open the XML file and find any elements, attributes, and attribute values that are unsupported in the CC. 25 Information Model.
   c. Change the unsupported elements, attributes, and attribute values to supported ones.
   d. Save and close the XML document.
2. Replace the doctype declaration in the XML code:
   a. In Notepad, open the XML file created with Epic Editor.
   b. Locate this doctype declaration and additional code at the beginning of the file:

```xml
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE book PUBLIC "-//Arbortext//DTD DocBook XML V4.0//EN" "..\..\program files\saxon\docbook412\docbookx.dtd">
```
c. Replace the XML code located in Step 2b with this:

```xml
<?xml version="1.0"?>
<!DOCTYPE book PUBLIC "-//HP//DTD DocBook XML V4.1.2-Based Extension NED-InfoModel V1.0//EN" "infomodel_v1.dtd">
```

Caution: Do not change any other XML code in the file. Doing so might create invalid XML.

d. Save and close the file.

3. Clean up the file as needed:
   a. In XMetaL, open the modified file.
   b. Delete extraneous text or processing instructions.

7.2.3. Constraints

7.2.3.1. Document to be opened must be in XML format.

7.2.3.2. Document to be opened must be on a local or network-connected drive.

7.2.3.3. Upon opening a DocBook document, displayed elements in the XML template are limited to those supported by the CC .25 Information Model.

7.2.3.4. XML-based documents must contain a doctype declaration to identify the governing DTD.

7.2.3.5. For XMetaL to automatically locate a DTD, the DTD must be in the same folder as the XML document being opened or in C:\Program Files\Corel\XMetaL4\Author\Rules.

7.2.3.6. Document to be opened can contain only those elements included in the CC .25 Information Model.

7.2.4. Related PRD Requirement(s)

Req #AT0-30, Req #PF1-10
7.3. Create a New DocBook Document

7.3.1. Description
Content-contributors must be able to use an XML authoring template to create technical publications (for example, manuals or online help systems). In addition, they must be able to use the template with or without a network connection. For the CC .25 release, supported renditions are HTML and HTML Help.

7.3.2. Use Case
1. Launch the XMetaL application with or without a network connection.
3. Select the IPDS tab. The Book.xml file, which is the IPDS XML Authoring Template, appears.
4. Select Book.xml, and click OK.
   • The template opens in the main document pane.
   • The default DocBook DTD and CSS are automatically associated with the template.
5. Select File>Save (Ctrl+S).
   Note: To prevent overwriting the IPDS XML Authoring Template, the Save As dialog box appears, displaying the directory in which the last open and save operation was performed.
6. Enter a file name. For file naming conventions, see the CC .25 Information Model.
7. Specify a different target location. Possible locations are:
   • Folder on the content-contributor’s local hard drive
   • Folder on a network-connected drive
8. Click Save.
   • The file is saved as specified.
   • The DocBook DTD and CSS installed with the IPDS authoring platform are automatically associated with the file.

7.3.3. Constraints
7.3.3.1. Upon opening the XML authoring template, displayed elements are limited to those supported by the CC .25 Information Model.
7.3.3.2. Upon opening the IPDS XML Authoring Template, the user interface must be configured as specified in XML Authoring Application.
7.3.3.3. The IPDS XML Authoring Template must contain a doctype declaration to identify the governing DTD.
7.3.3.4. For XMetaL to automatically locate a DTD, the DTD must be in the same folder as the XML document being opened or in C:\Program Files\Corel\XMetaL4\Author\Rules.

7.3.4. Related PRD Requirement(s)
Req #AT0-30, Req #AT1-203, Req #AT1-203-10, Req #AT1-203-20, Req #PF1-10, Req #MN1-10-30, Req #CC1-40
7.4. Save a DocBook Document

7.4.1. Description
Content-contributors must be able to save new or revised DocBook documents.

7.4.2. Use Cases

UC 40-10. Save an existing DocBook document with the same file name and target location.
1. Open a DocBook document in the XMetaL application as described in UC 20-10.
2. Modify the document.
3. Select File>Save (Ctrl+S).
   • The document is saved with the same name and to the same location as the previous version.
   • The DocBook DTD and CSS installed with the IPDS authoring platform are automatically associated with the file.

UC 40-20. Save an existing DocBook document with a different file name and target location.
1. Open a DocBook document in the XMetaL application as described in UC 20-10.
2. Modify the document.
3. Select File>Save As. The Save As dialog box appears, displaying the directory in which the last open and save operation was performed.
4. Enter a different file name. For file naming conventions, see the CC .25 Information Model.
5. Specify a different target location. Possible locations are:
   • Folder on the content-contributor's local hard drive
   • Folder on a network-connected drive
6. Click Save.
   • The file is saved as specified.
   • The DocBook DTD and CSS installed with the IPDS authoring platform are automatically associated with the file.

7.4.3. Constraint

7.4.3.1. Save operations shall comply with Microsoft Windows Application user guidelines.


7.4.4. Related PRD Requirement(s)
Req #AT0-30, Req #AT1-200, Req #AT1-215, Req #PF1-10, Req #PF1-30
7.5. Edit a DocBook Document

7.5.1. Description
Content-contributors must be able to perform standard editing operations for DocBook documents, including copying, cutting, pasting, and deleting content and surrounding markup.

7.5.2. Use Cases
UC 50-10. Copy and paste content and surrounding markup.
1. Open a DocBook document in the XMetaL application.
2. Select source content and markup by placing the cursor within the content and selecting Edit>Select Element (Ctrl-Shift-T).
3. Select Edit>Copy (Ctrl+C).
4. Position the cursor at a target location that is valid for the DTD.
5. Select Edit>Paste (Ctrl+V). XMetaL validates the paste operation.
   • If the operation is valid, content and surrounding markup (including attributes) are pasted into the DocBook document.
   • If the operation is invalid, it is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 4 and 5.

UC 50-20. Cut and paste content and surrounding markup.
1. Open a DocBook document in the XMetaL application.
2. Select source content and markup by placing the cursor within the content and selecting Edit>Select Element (Ctrl-Shift-T).
3. Select Edit>Cut (Ctrl+X).
4. Position the cursor at a target location that is valid for the DTD.
5. Select Edit>Paste (Ctrl+V). XMetaL validates the paste operation.
   • If the operation is valid, content and surrounding markup (including attributes) are pasted into the DocBook document.
   • If the operation is invalid, it is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 4 and 5.

UC 50-30. Delete content and surrounding markup.
1. Open a DocBook document in the XMetaL application.
2. Select source content and markup by placing the cursor within the content and selecting Edit>Select Element (Ctrl-Shift-T).
3. Select Edit>Delete (Del). XMetaL validates the delete operation.
   • If the operation is valid, content and surrounding markup (including attributes) are deleted from the DocBook document.
   • If the operation is invalid, it is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 2 and 3.

UC 50-40. Copy and paste an attribute value.
1. Open a DocBook document in the XMetaL application.
2. Position the cursor within the content assigned the applicable attribute value.
3. Select View>Attribute Inspector (Shift-F6).
4. Select the attribute value to be copied by double-clicking a single word or highlighting a phrase in the Attribute Inspector pane.
5. Select Edit>Copy (Ctrl+C).
6. Position the cursor at a target location in the Attribute Inspector pane that is valid for the DTD.
7. Select Edit>Paste (Ctrl+V). XMetaL validates the paste operation.
   • If the operation is valid, the attribute value is pasted into the DocBook document.
   • If the operation is invalid, it is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 6 and 7.
UC 50-50. Delete an attribute value.

1. Open a DocBook document in the XMetaL application.
2. Position the cursor within the content assigned the applicable attribute value.
3. Select View>Attribute Inspector (Shift-F6).
4. Select the attribute value to be deleted by double-clicking a single word or highlighting a phrase in the Attribute Inspector pane.
5. Select Edit>Delete (Del). XMetaL validates the delete operation.
   - If the operation is valid, content and surrounding markup (including attributes) are deleted from the DocBook document.
   - If the operation is invalid, it is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 2 and 3.

7. 5.3. Constraints
7. 5.3.1. The target location for pasted content and surrounding markup must be valid for the DTD.
7. 5.3.2. Content and surrounding markup cannot be deleted if doing so makes the structure invalid.

7. 5.4. Related PRD Requirement(s)
Req #AT0-30, Req #AT3-310, Req #AT3-310-10, Req #AT6-700-10, Req #AT6-700-20, Req #AT4-440,
Req #AT4-440-10, Req #PF1-10, Req #PF1-30, Req #AT1-200
7.6. Mark Content in a DocBook Document as Changed

7.6.1. Description

For content-consumers, content-contributors must be able to mark content as changed, added, or deleted. Content is marked in both review and final renditions by assigning the DocBook revisionflag attribute and the applicable value to modified content.

For reviewers and editors, content-contributors must be able to track changes to content. Changes are tracked in review renditions only by using XMetaL’s automatic revision tracking feature, which inserts DTD-neutral processing instructions in the XML code.

7.6.2. Use Cases

UC 60-10. Mark content as changed for content-consumers.
1. Open a DocBook document in the XMetaL application.
2. Select the content to be marked.
3. Select **Tools>Mark Changes>Changed** or right-click and select **Mark as Changed**.
   - XMetaL assigns the “Changed” value to the revisionflag attribute.
   - XMetaL applies onscreen formatting to content as specified in CSS.

UC 60-20. Mark content as added for content-consumers.
1. Open a DocBook document in the XMetaL application.
2. Select the content to be marked.
3. Select **Tools>Mark Changes>Added** or right-click and select **Mark as Added**.
   - XMetaL assigns the “Added” value to the revisionflag attribute.
   - XMetaL applies onscreen formatting to content as specified in CSS.

UC 60-30. Mark content as deleted for content-consumers.
1. Open a DocBook document in the XMetaL application.
2. Select the content to be marked.
3. Select **Tools>Mark Changes>Deleted** or right-click and select **Mark as Deleted**.
   - XMetaL assigns the “Deleted” value to the revisionflag attribute.
   - XMetaL applies onscreen formatting to content as specified in CSS.

UC 60-40. Remove change marks for content-consumers.
1. Open a DocBook document in the XMetaL application.
2. Select **Edit>Find Attribute**. The Find Attribute dialog box appears.
3. Configure the Find Attribute dialog box:
   a. Select **revisionflag** from the Find menu. The dialog box refreshes and populates the Value menu with valid revisionflag values.
   b. Select **changed** from the Value menu.
   c. Select **off** from the Replace menu.
4. Click **Find**. The first instance of the attribute value from the cursor position is highlighted.
5. To replace a single instance of the attribute value:
   a. Click **Replace**. The first instance is replaced, and the next instance is located.
   b. Click **OK** if you are prompted to resume the search from the beginning of the document.
   c. Click **OK** if the No Match Found dialog box is displayed.
6. To replace all instances in a single operation:
   a. Click **Replace All**.
   b. Click **OK** when prompted to acknowledge the number of replace operations successfully performed.
UC 60-50. Track content changes for reviewers or editors.
1. Open a DocBook document in the XMetaL application.
2. Verify that Tools>Track Changes is selected.
3. Insert and delete content in the DocBook document. Text insertions and deletions are displayed as configured in the Revision Mark Options dialog box.

UC 60-40. Remove change tracking for reviewers or editors.
1. Open a DocBook document in the XMetaL application.
2. Select Tools>Accept or Reject Changes.
3. In the Accept or Reject Changes dialog box:
   • Proceed from one change to the next and accept or reject each one. Accepted changes are maintained; rejected changes are deleted. All change marks are removed.
   • Accept all changes. All changes are maintained; all change marks are removed.
   • Reject all changes. All changes are deleted; all change marks are removed.

7.6.3. Constraints
7.6.3.1. Values for revisionflag are limited to those specified in the CC .25 Information Model.
7.6.3.2. Revision marks associated with XMetaL’s change tracking feature will not be included in final renditions.

7.6.4. Related PRD Requirement(s)
Req #DM1-35, Req #PF1-10, Req #PF1-30, Req #RD0-70, Req #RD0-78
7.7. Insert XML Boilerplate Into a DocBook Document

7.7.1. Description
Content-contributors must be able to insert IPDS XML boilerplates (content and surrounding markup) into their DocBook documents.

7.7.2. Use Cases

UC 70-10. Insert a glossary entry boilerplate into a DocBook document.
1. Open a DocBook document in the XMetaL application.
2. Position the cursor at a target location that is valid for the DTD.
3. Select Insert>Boilerplates>Glossary Entry. XMetaL validates the operation.
   • If the target location is valid, the boilerplate is inserted.
   • If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 2 and 3.

UC 70-20. Insert a block image boilerplate into a DocBook document.
1. Open a DocBook document in the XMetaL application.
2. Insert parent elements as needed (for example, <figure>, <informalfigure>, <screenshot>, <example>, or <informalexample>).
3. Position the cursor at a target location that is valid for the DTD.
4. Select Insert>Boilerplates>Block Image. XMetaL validates the operation.
   • If the target location is valid, the boilerplate is inserted and the Choose Image File dialog box is automatically displayed.
   • If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 3 and 4.
5. To insert an image, navigate to and select an image, and click OK. The selected image is inserted by reference.
6. To insert an image later, click Cancel. The Choose Image File dialog box is dismissed, and the click_here_to_insert_image link in the boilerplate remains available for future use.

Alternative
1. Perform Steps 1 through 3, UC 70-20.
2. Select Insert>Image>Block. XMetaL validates the operation.
   • If the target location is valid, the block image boilerplate is inserted and the Choose Image File dialog box is automatically displayed.
   • If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Reposition the cursor to a valid location and repeat Step 2.
3. To insert an image, navigate to and select an image, and click OK. The selected image is inserted by reference.
4. To insert an image later, click Cancel. The Choose Image File dialog box is dismissed, and the click_here_to_insert_image link in the boilerplate remains available for future use.

UC 70-30. Insert an inline image boilerplate into a DocBook document.
1. Open a DocBook document in the XMetaL application.
2. Insert parent elements as needed (for example, <para>).
3. Position the cursor at a target location that is valid for the DTD.
4. Select Insert>Boilerplates>Inline Image. XMetaL validates the operation.
   • If the target location is valid, the boilerplate is inserted and the Choose Image File dialog box is displayed.
   • If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 3 and 4.
5. To insert an image, navigate to and select an image, and click OK. The selected image is inserted by reference.
6. To insert an image later, click **Cancel**. The Choose Image File dialog box is dismissed, and the click_here_to_insert_image link in the boilerplate remains available for future use.

Alternative

1. Perform Steps 1 through 3, UC 70-30.
2. Select **Insert>Image>Inline**. XMetaL validates the operation.
   - If the target location is valid, the inline image boilerplate is inserted and the Choose Image File dialog box is displayed.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Reposition the cursor to a valid location and repeat Step 2.
3. To insert an image, navigate to and select an image, and click **OK**. The selected image is inserted by reference.
4. To insert an image later, click **Cancel**. The Choose Image File dialog box is dismissed, and the click_here_to_insert_image link in the boilerplate remains available for future use.

UC 70-40. Insert a numbered message boilerplate into a DocBook document.

1. Open a DocBook document in the XMetaL application.
2. Insert parent elements as needed (for example, <msgset>).
3. Position the cursor at a target location that is valid for the DTD.
4. Select **Insert>Boilerplates>Numbered Message**. XMetaL validates the operation.
   - If the target location is valid, the boilerplate is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Repeat Steps 3 and 4.

UC 70-50. Insert an unnumbered message boilerplate into a DocBook document.

1. Open a DocBook document in the XMetaL application.
2. Insert parent elements as needed (for example, <msgset>).
3. Position the cursor at a target location that is valid for the DTD.
4. Select **Insert>Boilerplates>Unnumbered Message**. XMetaL validates the operation.
   - If the target location is valid, the boilerplate is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Repeat Steps 3 and 4.

UC 70-60. Insert the Legal Notices boilerplate into a DocBook document.

1. Open a DocBook document in the XMetaL application.
2. Insert parent elements as needed (for example, <legalnotice>.
3. Insert opening and closing <title> elements and enter “Legal Notices” as the title.
4. Position the cursor at a target location that is valid for the DTD.
5. Select **Insert>Boilerplates>Legal Notices**. XMetaL validates the operation.
   - If the target location is valid, the boilerplate is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Repeat Steps 4 and 5.

UC 70-70. Insert the partition boilerplate into a DocBook document.

1. Open a DocBook document in the XMetaL application.
2. Position the cursor at a target location that is valid for the DTD.
3. Select **Insert>Boilerplates>Partition**. XMetaL validates the operation.
   - If the target location is valid, the boilerplate is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Repeat Steps 2 and 3.

UC 70-80. Insert the question and answer boilerplate into a DocBook document.

1. Open a DocBook document in the XMetaL application.
2. Insert parent elements as needed (for example, <qandaset>).
3. Position the cursor at a target location that is valid for the DTD.
4. Select **Insert>Boilerplates>Question and Answer**. XMetaL validates the operation.
   - If the target location is valid, the boilerplate is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Repeat Steps 3 and 4.

UC 70-90. Insert the term and definition boilerplate into a DocBook document.
1. Open a DocBook document in the XMetaL application.
2. Position the cursor at a target location that is valid for the DTD.
3. Select **Insert>Boilerplates>Term and Definition**. XMetaL validates the operation.
   - If the target location is valid, the boilerplate is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Repeat Steps 2 and 3.

UC 70-100. Insert an event message boilerplate into a DocBook document.
10. Insert parent elements as needed (for example, `<msgset>`).
11. Position the cursor at a target location that is valid for the DTD.
12. Select **Insert>Boilerplates>Event Message**. XMetaL validates the operation.
   - If the target location is valid, the boilerplate is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click **OK** to dismiss the dialog box. Repeat Steps 3 and 4.

7.7.3. **Constraints**
7.7.3.1. The insertion location for a boilerplate must be valid for the DTD.

7.7.4. **Related PRD Requirement(s)**
- Req #AT6-700-10, Req #AT6-700-20, Req #CM3-70-20, Req #PF1-10, Req #PF1-30
7.8. Insert an Image Into a DocBook Document

7.8.1. Description
Content-contributors must be able to insert block or inline images by reference into their DocBook documents.

7.8.2. Use Cases
UC 80-10. Insert a block image by reference (block image boilerplate is not already inserted).
1. Same as UC 70-20.

UC 80-20. Insert a block image by reference (block image boilerplate is already inserted).
1. Open a DocBook document in the XMetaL application.
2. Do one of these:
   • To insert an image for the first time, locate and click the “click_here_to_insert_image” link. The Choose Image File dialog box appears.
   • To replace the existing image, single-click the image. When prompted to replace the current image, click OK. The Choose Image File dialog box appears.
   • To replace the existing image, delete the image by selecting it and pressing Del. The image is replaced by the “click_here_to_insert_image” link. Click the link. The Choose Image File dialog box appears.
3. Navigate to and select the applicable image.
4. Click OK. The image is inserted by reference.

UC 80-30. Insert an inline image by reference (inline image boilerplate is not already inserted).
1. Same as UC 70-30.

UC 80-40. Insert an inline image by reference (inline image boilerplate is already inserted).
1. Open a DocBook document in the XMetaL application.
2. Do one of these:
   • To insert an image for the first time, locate and click the “click_here_to_insert_image” link. The Choose Image File dialog box appears.
   • To replace the existing image, single-click the image. When prompted to replace the current image, click OK. The Choose Image File dialog box appears.
   • To replace the existing image, delete the image by selecting it and pressing Del. The image is replaced by the “click_here_to_insert_image” link. Click the link. The Choose Image File dialog box appears.
3. Navigate to and select the applicable image.
4. Click OK. The image is inserted by reference.

7.8.3. Constraints
7.8.3.1. The insertion location for a block or inline image boilerplate must be valid for the DTD.
7.8.3.2. The non-XML file format must be supported for insertion in a DocBook document.

7.8.4. Related PRD Requirement(s)
Req #AT6-700-10, Req #AT6-700-20, Req #PF1-10, Req #PF1-30
7.9. Find or Replace Content in a DocBook Document

7.9.1. Description
Content contributors must be able to find and find/replace content in DocBook documents, including words, phrases, elements, attributes, and attribute values.

7.9.2. Use Cases

UC 90-10. Find an element.

1. Open a DocBook document in the XMetaL application
2. Select Edit>Find and Replace (Ctrl+F).
3. Configure the Find and Replace dialog box:
   a. Select the Element tab if it is not already active.
   b. Select an element from the Find menu.
4. Click Find. The first instance of the element from the cursor position is located.
5. To find the next instance of the search value, click Find again.

Note: If you are prompted to resume the search from the beginning of the document, click OK. If the No Match Found dialog box is displayed, click OK.

6. To find the previous instance of the search value:
   a. Click Options to expand the dialog box.
   b. Select Search Backwards.
   c. Click Find again.

Note: If you are prompted to resume the search from the end of the document, click OK. If the No Match Found dialog box is displayed, click OK.

UC 90-40. Find and replace an element.

1. Perform Steps 1 through 3 in UC 90-10.
2. From the Replace with menu, select a different element.
3. To replace a single instance of the element, click Replace. The first instance of the element from the cursor position is replaced, and the next instance is located.

Note: If you are prompted to resume the search from the beginning of the document, click OK. If the No Match Found dialog box is displayed, click OK.

4. To replace all instances in a single operation:
   a. Click Replace All.
   b. When prompted to acknowledge the number of replace operations successfully performed, click OK.

UC 90-50. Find an attribute.

1. Open a DocBook document in the XMetaL application.
2. Select Edit>Find Attribute. The Find Attribute dialog box appears.
3. Select an attribute from the Find menu.
4. Click Find. The first instance of the attribute from the cursor position is located.
5. To find the next instance of the search value, click Find again.

Note: If you are prompted to resume the search from the beginning of the document, click OK. If the No Match Found dialog box is displayed, click OK.

6. To find the previous instance of the search value:
   a. Click Options to expand the dialog box.
   b. Select Search Backwards.
   c. Click Find again.

Note: If you are prompted to resume the search from the end of the document, click OK. If the No Match Found dialog box is displayed, click OK.
UC 90-60. Find and replace an attribute.
1. Perform Steps 1 through 3 in UC 90-50.
2. From the Replace with menu, select a different attribute.
3. To replace a single instance of the attribute, click Replace. The first instance of the element from the
cursor position is replaced, and the next instance is located.

   Note: If you are prompted to resume the search from the beginning of the document, click OK. If the
   No Match Found dialog box is displayed, click OK.

4. To replace all instances in a single operation:
   a. Click Replace All.
   b. When prompted to acknowledge the number of replace operations successfully performed,
      click OK.

UC 90-70. Find an attribute value.
1. Open a DocBook document in the XMetaL application.
2. Select Edit>Find Attribute. The Find Attribute dialog box appears.
3. Configure the Find Attribute dialog box:
   a. From the Find menu, select an attribute. The dialog box refreshes and populates the Value
      menu with valid attribute values.
   b. Select an attribute value from the Value menu.
4. Click Find. The first instance of the attribute value from the cursor position is located.
5. To find the next instance of the search value, click Find again.

   Note: If you are prompted to resume the search from the beginning of the document, click OK. If the
   No Match Found dialog box is displayed, click OK.
6. To find the previous instance of the search value:
   a. Click Options to expand the dialog box.
   b. Select Search Backwards.
   c. Click Find again.

   Note: If you are prompted to resume the search from the end of the document, click OK. If the
   No Match Found dialog box is displayed, click OK.

UC 90-80. Find and replace an attribute value.
1. Perform Steps 1 through 3 in UC 90-70.
2. From the Replace with menu, select a different attribute value.
3. To replace a single instance of the attribute value, click Replace. The first instance is replaced, and
   the next instance is located.

   Note: If you are prompted to resume the search from the beginning of the document, click OK. If the
   No Match Found dialog box is displayed, click OK.
4. To replace all instances in a single operation:
   a. Click Replace All.
   b. When prompted to acknowledge the number of replace operations successfully performed,
      click OK.

7.9.3. Constraints
7.9.3.1. For a replace operation, the replacement element, attribute, or attribute value must be valid for
the DTD.

7.9.4. PRD Requirement(s)
Req #AT4-510, Req #AT4-510-10, Req #AT4-510-20, Req #AT4-510-30, Req #AT4-510-40, Req #AT4-
510-50, Req #AT4-510-60, Req #AT4-510-70, Req #AT4-510-80, Req #AT4-510-90, Req #AT4-600, Req
#AT4-600-20, Req #AT4-600-30, Req #AT4-600-40, Req #AT4-600-50, Req #AT4-600-60, Req #AT4-
600-70, Req #AT4-600-80, Req #AT4-600-90, Req #AT4-600-100, Req #AT4-600-110, Req #AT6-700-
10, Req #AT6-700-20, Req #PF1-10, Req #PF1-30
7.10. Insert or Change a DocBook Element

7.10.1. Description
Content-contributors must be able to insert valid DocBook elements. In addition, they must be able to change a DocBook element to another valid element.

7.10.2. Use Cases
UC 100-10. Insert a DocBook element.
1. Open a DocBook document in the XMetaL application.
2. Position the cursor at a location that is valid for the element to be inserted.
3. Select **Insert>Element**. The Element List switches to Insert mode if it is not already in it.
4. In the Element List pane, select the element to be inserted, and click **Apply**. The element is inserted.

UC 100-20. Change a DocBook element.
1. Open a DocBook document in the XMetaL application.
2. Position the cursor within the element to be changed.
3. Select **Edit>Change Element**. The Element List switches to Change mode if it is not already in it.
4. Select the new element to replace the existing element, and click **Apply**. The element is changed.

7.10.3. Constraints
7.10.3.1. Only elements included in the CC .25 Information Model and allowed by the DocBook 4.1.2 DTD can be inserted in a DocBook document.
7.10.3.2. The Element List displays only the elements included in the CC .25 Information Model.
7.10.3.3. Required child elements must be inserted with their parent elements as specified in the CC .25 Information Model.
7.10.3.4. When changing an element, the new element must be valid for the DTD.

7.10.4. Related PRD Requirement(s)
Req #AT6-700-10, Req #AT6-700-20, Req #AT4-450, Req #AT3-310, Req #AT3-310-10, Req #PF1-10, Req #PF1-30
7.11. Mark Content for Profiling

7.11.1. Description
Content-contributors must be able to mark content for profiling so that different content renditions can be generated from the same source file. The currently required profiles are programming language, release series, hidden text, modified content, and OCA or Accelerator manual.

7.11.2. Use Cases

UC 110-10. Profile content by programming language.
1. Open a DocBook document in the XMetaL application.
2. In the main document pane, place the cursor within the applicable element.
3. Select View>Attribute Inspector. The Attribute Inspector pane appears, listing supported attributes only.
4. Locate and select the arch attribute, and select the Java, Cplusplus, or Java+Cplusplus value. The attribute and value are applied to the element.
5. Press Enter. The attribute and value are applied to the element.

UC 110-20. Profile content by release series.
1. Open a DocBook document in the XMetaL application.
2. In the main document pane, place the cursor within the applicable element.
3. Select View>Attribute Inspector. The Attribute Inspector pane appears, listing supported attributes only.
4. Locate and select the os attribute, and select the gseries, hseries, or gseries+hseries value. The attribute and value are applied to the element.
5. Press Enter. The attribute and value are applied to the element.

UC 110-30. Profile content as hidden text.
2. In the main document pane, place the cursor within the applicable element.
3. Select View>Attribute Inspector. The Attribute Inspector pane appears, listing supported attributes only.
4. Locate and select the condition attribute, and select the hidden value. The attribute and value are applied to the element.
5. Press Enter. The attribute and value are applied to the element.

UC 110-40. Profile content for either the OCA or Accelerator publication.
2. In the main document pane, place the cursor within the applicable element.
3. Select View>Attribute Inspector. The Attribute Inspector pane appears, listing supported attributes only.
4. Locate and select the arch attribute, and select the OCA or Accelerator value. The attribute and value are applied to the element.
5. Press Enter. The attribute and value are applied to the element.

UC 110-50. Profile content as modified (that is, changed, added, or deleted).
1. Same as UC 60-10, UC 60-20, and UC 60-30.

UC 110-60. Remove a profile from content.
2. In the main document pane, place the cursor within the applicable element.
3. Select View>Attribute Inspector. The Attribute Inspector pane appears, listing supported attributes only.
4. Locate the arch, os, or condition attribute, and select the none value, or locate the revisionflag attribute and select the off value. The attribute and value are deleted from the element.
7.11.3. Constraints

7.11.3.1. Only the common attributes and their enumerated values identified in the CC .25 Information Model are supported.

7.11.4. Related PRD Requirement(s)

Req #DM1-20, Req #DM1-20-10, Req #DM1-20-20, Req #DM1-30, Req #DM1-120, Req #DM1-125-10, Req #PF1-10, Req #PF1-30, Req #RD0-75, Req #TR1-60
7.12. Enter Comments to Reviewers or Content-Contributors

7.12.1. Description

Content-contributors must be able to enter comments to reviewers or other content-contributors in DocBook documents.

- The `<remark>` element will be used to mark text as a comment to reviewers. The text will be included in review renditions only.
- XMetaL’s Insert>Comment command (renamed as Insert>Comment to Writer) will be used to mark text as a comment to other content-contributors. The command inserts a DTD-neutral processing instruction in the XML code. The text will not be included in review or final renditions.

7.12.2. Use Cases

UC 120-10. Enter comments to reviewers.
1. Open a DocBook document in the XMetaL application.
2. In the main document pane, decide where to place the comment and position the cursor.
3. Select Insert>Comment to Reviewer. XMetaL validates the operation.
   - If the target location is valid, the `<remark>` element is inserted.
   - If the target location is invalid, the operation is not performed and an error message dialog box is displayed. Click OK to dismiss the dialog box. Repeat Steps 2 and 3.
4. Enter comment text within the `<remark>` element. The text is displayed as configured in the CSS.

UC 120-20. Enter comments to content-contributors.
1. Open a DocBook document in the XMetaL application.
2. In the main document pane, decide where to place the comment and position the cursor.
3. Select Insert>Comment to Writer. The processing instruction is inserted.
4. Enter comment text within the processing instruction. The text is displayed as configured in the CSS.

7.12.3. Constraints

7.12.3.1. The insertion location of the `<remark>` element must be valid for the data model.
7.12.3.2. Comments to reviewers will be included in review renditions only.
7.12.3.3. Comments to writers will not be included in review or final renditions.

7.12.4. Related PRD Requirement(s)
Req #DM1-110, Req #PF1-10, Req #PF1-30, Req #RD0-76
7.13. Generate a Preview Rendition of a DocBook Document

7.13.1. Description
Content-contributors must be able to generate onscreen previews of their DocBook documents with or without a network connection. Previews are rendered in an IE browser window according to the CSS associated with the DTD.

Note: Review (HTML or HTML Help format for reviewers) and final renditions (HTML or HTML Help format for customers) are rendered by a transformation engine separate from the authoring tool.

7.13.2. Use Cases
1. Open the DocBook document to be previewed.
2. Select View>Browser Preview (Ctrl + Shift + V). An Internet Explorer browser window opens and the preview rendition appears in the window.

Note: Although the document cannot be edited in this mode, links are active and testable.

UC 130-20. Preview a DocBook document without a network connection.
1. Same as UC 130-10.

7.13.3. Constraints
7.13.3.1. Content to be previewed must be well-formed and valid to the data model.

7.13.4. Related PRD Requirement(s)
Req #AT3-315, Req # AT6-710-10, Req #RD0-20, Req #RD0-20-10, Req #PF1-10, Req #PF1-30

7.14.1. Description
Content-contributors must be able to insert hyperlinks within their DocBook documents to targets within the same document, within another document in the same set, or on the World Wide Web (WWW). In addition, content-contributors must be able to validate hyperlinks.

7.14.2. Use Cases
UC 140-10. Insert a link to a target in the same document or set.
1. Position the cursor at the target location, and select \texttt{Insert>Link Target}.
2. In the Insert Link Target dialog box, enter a name for the target anchor and click \texttt{OK}.
3. Highlight the text that will be used as the link.
4. Select \texttt{Insert>Link}.
5. In the Insert Link dialog box, select the \texttt{Current Document} option.
6. Select the applicable anchor from the target list, and click \texttt{OK}. The link is inserted and is displayed as blue, underlined text.

\textbf{Note:} To validate a link, double-click the link in Normal or Tags On view and verify its target.

1. Highlight the text that will be used as the link.
2. Select \texttt{Insert>Link}.
3. In the Insert Link dialog box, select the \texttt{Web} option.
4. Enter the target's URL, and click \texttt{OK}. The link is inserted and is displayed as blue, underlined text.

\textbf{Note:} To validate a link, double-click the link in Normal or Tags On view and verify its target.

7.14.3. Constraints
7.14.3.1. A link target must reside within the same \texttt{<book>} element.
7.14.3.2. A network connection is required to validate links to the WWW.
7.14.3.3. A link target must be valid and available.

7.14.4. Related PRD Requirement(s)
- Req \#AT3-320, Req \#AT3-325, Req \#AT3-325-10, Req \#AT3-325-20, Req \#AT3-320-10, Req \#AT3-320-20, Req \#AT3-370, Req \#AT3-330, Req \#AT3-330-10, Req \#AT3-330-20, Req \#AT3-330-30, Req \#PF1-10, Req \#PF1-30, Req \#DM1-10, Req \#DM1-10-10, Req \#DM1-10-20
7.15. **Auto-Save Work In Progress**

7.15.1. **Description**

Content-contributors must be able to configure the XMetaL application to save their open DocBook documents automatically after a specified period of time or number of editing changes.

7.15.2. **Use Cases**

UC 160-10. Auto-save work in progress.

1. Launch the XMetaL application.
2. Select **Tools>Options**. The Options dialog box appears.
3. Configure the Automatic Saves section of the dialog box, and click **OK**.
4. Open and revise a DocBook document.
5. After the specified number of changes or minutes, XMetaL validates the document.
   - If the document is valid, XMetaL automatically saves it. No validation log is displayed.
   - **Note:** If the content-contributor selected **Tools>Options>Ask before saving**, XMetaL prompts you to approve the save operation before saving the document. Click **Save**.
   - If the document is invalid, XMetaL does not save it but displays a validation log.

7.15.3. **Constraints**

7.15.3.1. XMetaL cannot perform an auto-save operation without displaying a validation log.

7.15.3.2. Content-contributors will be prompted to auto-save a document only if the Ask before saving option is selected in the Option dialog box.

7.15.4. **Related PRD Requirement(s)**

- Req #AT0-25-10, Req #PF1-10, Req #PF1-30
7.16. Print a DocBook Document

7.16.1. Description
Content-contributors must be able to print all or portions of their DocBook documents in Tags On (tagged source), Normal, or Browser Preview modes. In addition, content-contributors must be able to display a preview of a DocBook document before printing it.

7.16.2. Use Cases

1. Open a DocBook document in the XMetaL application.
2. Select View>Tags On (Ctrl+Shift+O) if it is not already selected. Tags appear within the document.
3. Select File>Print (Ctrl+P). The Print dialog box appears.
4. Configure the Print dialog box as needed.
5. Click Print. The DocBook document prints with starting and ending tags visible.

UC 170-20. Print a DocBook document in Normal mode.
1. Open a DocBook document in the XMetaL application.
2. Select View>Normal (Ctrl+Shift+W) if it is not already selected. The document is displayed without tags.
3. Select File>Print (Ctrl+P). The Print dialog box appears.
4. Configure the Print dialog box as needed.
5. Click Print. The DocBook document prints as it appears onscreen.

UC 170-30. Print a DocBook document in Browser Preview mode.
1. Open a DocBook document in the XMetaL application.
2. Select View>Browser Preview (Ctrl+Shift+V). An Internet Explorer browser window opens and the preview rendition appears in the window.
3. In the browser window, select File>Print (Ctrl+P). The Print dialog box appears.
4. Configure the Print dialog box as needed.
5. Click Print. The DocBook document prints as it would appear in an Internet Explorer browser.

UC 170-40. Preview a DocBook document before printing.
1. Open a DocBook document in the XMetaL application.
2. Select View>Browser Preview (Ctrl+Shift+V). An Internet Explorer browser window opens and the preview rendition appears in the window.
3. In the browser window, select File>Print Preview. The DocBook document is displayed like it would print on an 8.5 x 11 inch page.

7.16.3. Constraints

7.16.3.1. A local or network-connected printer must be available and operational.

7.16.4. Related PRD Requirement(s)

Req #AT2-220, Req #AT2-220-05, Req #AT2-220-20, Req #AT2-220-25, Req #PF1-10, Req #PF1-30
7.17. Perform a Spell-Check on a DocBook Document

7.17.1. Description
Content-contributors must be able to check the spelling of content within their DocBook documents.

7.17.2. Use Cases
UC 180-10. Check spelling within a DocBook document.

1. Open a DocBook document in the XMetaL application.
2. Select Tools>Spell Checker (F7). The Writing Tools dialog box opens with the Spell Checker tab active.
3. Select Check:Document. Click Start. XMetaL finds the first instance of a misspelled or questionable word, querying the main word list first and then the user word list.
4. Perform one of these:
   • Click Add to add the word to the user word list.
   • Click Replace to replace the first instance. The next instance is identified.
   • Click Skip to skip the first instance.
5. Repeat Step 5 until the remainder of the document has been checked.

7.17.3. Constraints
7.17.3.1. The spell-check operation excludes elements, attributes, and attribute values.

7.17.4. Related PRD Requirement(s)
Req #AT3-340, Req #AT3-340-10, Req #PF1-10, Req #PF1-30
7.18. **Copy FrameMaker Text Into a DocBook Document**

7.18.1. **Description**

Content-contributors must be able to copy body text from a FrameMaker Tools (FMT) file and paste it into a DocBook document.

7.18.2. **Use Cases**

UC 200-10. Copy FMT body text into a DocBook document.

1. Open an FMT file in FrameMaker 6.0.
2. Open a DocBook document in the XMetaL application.
3. In the FMT file, select body text (for example, a level 1 heading, paragraph, or numbered list) and select **Edit>Copy** (Ctrl+C). The text is copied to the clipboard.
4. Switch to the DocBook document:
   a. Insert the corresponding XML element (for example, `<sect1>` for a level 1 heading, `<para>` for a paragraph, or `<orderedlist>` for a numbered list).
   b. With the cursor within the inserted element, select **Edit>Paste** (Ctrl+V). The body text copied in Step 3 is copied from the clipboard into the element.
   c. Insert additional elements (for example, `<emphasis>` or `<citetitle>`) as needed.
   d. Insert special characters as needed so that they transform correctly in renditions.

7.18.3. **Constraints**

7.18.3.1. The copying and pasting of FMT body text only is supported; the copying and pasting of images is not supported.

7.18.3.2. Inserted elements must be valid for the data model.

7.18.4. **Related PRD Requirement(s)**

Req #CO1-10, Req #PF1-10, Req #PF1-30, Req #AT3-10, Req #AT3-10-10
7.19. Change the Font Size in Editing Mode

7.19.1. Description
When authoring, content-contributors must be able to increase or decrease the font size of DocBook documents in the main document pane.

7.19.2. Use Cases
UC 190-10. Increase the font size.
1. Open a DocBook document in the XMetaL application.
2. Select View>Increase Font. XMetaL increases all font sizes proportionately as specified in the CSS.

UC 190-20. Decrease the font size.
1. Open a DocBook document in the XMetaL application.
2. Select View>Decrease Font. XMetaL decreases all font sizes proportionately as specified in the CSS.

7.19.3. Constraints
7.19.3.1. When View>Increase Font is grayed out, the font size is at the maximum and cannot be increased.
7.19.3.2. When View>Decrease Font is grayed out, the font size is at the minimum and cannot be decreased.

7.19.4. Related PRD Requirement(s)
Req #ST1-50